「お使いのブラウザのバージョンに対応していません。」と表示されます

Cookpad Do!では以下の環境を推奨しています。
推奨環境について

非推奨ブラウザでアクセスした場合、「お使いのブラウザのバージョンに対応していません。」と表示され、サイトが正しく表示できない場合がございます。
お手数ですが、Google Chrome 最新版をインストールしてアクセスしてください。
Google Chromeとはなんですか